<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Hi Kebba,<br>
<br>
Ok, your exim logs have told me what the problem likely is.&nbsp; That is,
the "condition check lookup defer" log message in the
ditch_spam_for_relay_MX_direct router indicates that exim may not be
successfully reading the mysql database.&nbsp; While I am not 100% certain
that this is your problem, this has been the problem every time I have
previously seen that in the logs.&nbsp; Exim shouldn't even be executing
that router for your welcome message and the only way that I can figure
why is if exim is not reading the mysql database.<br>
<br>
You therefore need to verify all of your configuration settings for
exim's access to the mysql database.&nbsp; Check this line in
/etc/exim4u_local.conf.inc:<br>
<br>
hide mysql_servers =
localhost::(/var/lib/mysql/mysql.sock)/exim4u/exim4u/CHANGE<br>
<br>
For your Debian installation, this line should read:<br>
<br>
hide mysql_servers =
localhost::(/var/run/mysqld/mysqld.sock)/exim4u/Debian-exim/CHANGE<br>
<br>
That is, the default socket file name is /var/run/mysqld/mysqld.sock in
Debian/Ubuntu whereas the default socket file name of
/var/lib/mysql/mysql.sock is correct for Red Hat and CentOS. Also,
replace CHANGE with your password.&nbsp; This also assumes that you are
running exim under the Debian-exim username.&nbsp; If that is not the case
then replace Debian-exim with the username that you are running exim
under.<br>
<br>
FYI,<br>
<br>
Gordon<br>
<br>
<br>
<br>
<a class="moz-txt-link-abbreviated" href="mailto:kebba.foon@qcell.gm">kebba.foon@qcell.gm</a>
wrote:
<blockquote
 cite="mid:41b3150a386fc603e5b113bbf4372afe.squirrel@www.qmail.gm"
 type="cite">
  <pre wrap="">Hi Gordon,

Checking my exim mail queue i saw pending mails to the new domains i created:
2010-01-22 12:22:28 Received from <a class="moz-txt-link-abbreviated"
 href="mailto:www-data@mydomain.gm">www-data@mydomain.gm</a> U=www-data P=local
S=601 T="Welcome Domain Admin!"
2010-01-22 12:22:28 <a class="moz-txt-link-abbreviated"
 href="mailto:postmaster@mydomin.gm">postmaster@mydomin.gm</a> R=ditch_spam_for_relay_MX_direct
defer (-1): condition check lookup defer

i dont know if this mean anything, but the welcome mail seems to be seen
when the domain is initially created on the mysql.

Kebba


  </pre>
  <blockquote type="cite">
    <pre wrap="">Send users mailing list submissions to
        <a class="moz-txt-link-abbreviated" href="mailto:users@exim4u.org">users@exim4u.org</a>

To subscribe or unsubscribe via the World Wide Web, visit
        <a class="moz-txt-link-freetext"
 href="https://exim4u.org/mailman/listinfo/users">https://exim4u.org/mailman/listinfo/users</a>
or, via email, send a message with subject or body 'help' to
        <a class="moz-txt-link-abbreviated"
 href="mailto:users-request@exim4u.org">users-request@exim4u.org</a>

You can reach the person managing the list at
        <a class="moz-txt-link-abbreviated"
 href="mailto:users-owner@exim4u.org">users-owner@exim4u.org</a>

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."


Today's Topics:

   1. Re: domains got create at mysql level but not on system        level
      (<a class="moz-txt-link-abbreviated"
 href="mailto:kebba.foon@qcell.gm">kebba.foon@qcell.gm</a>)
   2. Re: domains got create at mysql level but not on system level
      (Gordon Dickens)


----------------------------------------------------------------------

Message: 1
Date: Fri, 22 Jan 2010 18:05:43 -0000 (GMT)
From: <a class="moz-txt-link-abbreviated"
 href="mailto:kebba.foon@qcell.gm">kebba.foon@qcell.gm</a>
Subject: Re: [Exim4U] domains got create at mysql level but not on
        system        level
To: <a class="moz-txt-link-abbreviated" href="mailto:users@exim4u.org">users@exim4u.org</a>
Message-ID: <a class="moz-txt-link-rfc2396E"
 href="mailto:f1bb2457704bae22bf1bb699204a4fa3.squirrel@www.qmail.gm">&lt;f1bb2457704bae22bf1bb699204a4fa3.squirrel@www.qmail.gm&gt;</a>
Content-Type: text/plain;charset=iso-8859-1

i have check the permissions and everything is find if i login with the
users the mail boxes belong to i can create directories, i have check and
cross check my permission i even created a tmp folder with 777 permission.
i dont see any permission error if i check my apache logs. am using debian

    </pre>
    <blockquote type="cite">
      <pre wrap="">Send users mailing list submissions to
        <a class="moz-txt-link-abbreviated" href="mailto:users@exim4u.org">users@exim4u.org</a>

To subscribe or unsubscribe via the World Wide Web, visit
        <a class="moz-txt-link-freetext"
 href="https://exim4u.org/mailman/listinfo/users">https://exim4u.org/mailman/listinfo/users</a>
or, via email, send a message with subject or body 'help' to
        <a class="moz-txt-link-abbreviated"
 href="mailto:users-request@exim4u.org">users-request@exim4u.org</a>

You can reach the person managing the list at
        <a class="moz-txt-link-abbreviated"
 href="mailto:users-owner@exim4u.org">users-owner@exim4u.org</a>

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."


Today's Topics:

   1. domains got create at mysql level but not on system level
      (<a class="moz-txt-link-abbreviated"
 href="mailto:kebba.foon@qcell.gm">kebba.foon@qcell.gm</a>)
   2. Re: domains got create at mysql level but not on system level
      (Gordon Dickens)


----------------------------------------------------------------------

Message: 1
Date: Fri, 22 Jan 2010 13:12:57 -0000 (GMT)
From: <a class="moz-txt-link-abbreviated"
 href="mailto:kebba.foon@qcell.gm">kebba.foon@qcell.gm</a>
Subject: [Exim4U] domains got create at mysql level but not on system
        level
To: <a class="moz-txt-link-abbreviated" href="mailto:users@exim4u.org">users@exim4u.org</a>
Message-ID: <a class="moz-txt-link-rfc2396E"
 href="mailto:696d817ecfd375369f9ec92157bf8d89.squirrel@www.qmail.gm">&lt;696d817ecfd375369f9ec92157bf8d89.squirrel@www.qmail.gm&gt;</a>
Content-Type: text/plain;charset=iso-8859-1

HI

i am testing the exim4u email server, i have followed the installation
instruction on the website and did everything. the exim daemon is
running.
when i create users on the exim4u web interface, the users got created
on
the mysql database but there is no domain folder created on system for
exim. i created a user for the system gid and uid. i dont know what am
doing wrong please help, i cannot find out anything in the logs.

Kebba






------------------------------

Message: 2
Date: Fri, 22 Jan 2010 08:18:29 -0500
From: Gordon Dickens <a class="moz-txt-link-rfc2396E"
 href="mailto:gecko@exim4u.org">&lt;gecko@exim4u.org&gt;</a>
Subject: Re: [Exim4U] domains got create at mysql level but not on
        system level
To: Exim4U General Discussion <a class="moz-txt-link-rfc2396E"
 href="mailto:users@exim4u.org">&lt;users@exim4u.org&gt;</a>
Message-ID: <a class="moz-txt-link-rfc2396E"
 href="mailto:4B59A5A5.9030907@exim4u.org">&lt;4B59A5A5.9030907@exim4u.org&gt;</a>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Hello,

This is most likely an operating system permissions issue.  Please check
the permissions of your mail store's parent directory.

If you haven't done so, you may need to create a mail store folder in
the directory where you are storing your mail.  For example, if you are
storing your mail in the directory:

    /home/exim4u/mail

Then, you need to create the mail folder as follows:

    mkdir /home/exim4u/mail

Also, make sure that your mail store directory is writable by the
uid/gid that you specified when you created the domain in Exim4U's email
admin.

Good luck and thanks for using Exim4U.

Gordon Dickens



<a class="moz-txt-link-abbreviated" href="mailto:kebba.foon@qcell.gm">kebba.foon@qcell.gm</a> wrote:
      </pre>
      <blockquote type="cite">
        <pre wrap="">HI

i am testing the exim4u email server, i have followed the installation
instruction on the website and did everything. the exim daemon is
running.
when i create users on the exim4u web interface, the users got created
on
the mysql database but there is no domain folder created on system for
exim. i created a user for the system gid and uid. i dont know what am
doing wrong please help, i cannot find out anything in the logs.

Kebba




_______________________________________________
users mailing list
<a class="moz-txt-link-abbreviated" href="mailto:users@exim4u.org">users@exim4u.org</a>
<a class="moz-txt-link-freetext"
 href="https://exim4u.org/mailman/listinfo/users">https://exim4u.org/mailman/listinfo/users</a>

        </pre>
      </blockquote>
      <pre wrap="">

------------------------------

_______________________________________________
users mailing list
<a class="moz-txt-link-abbreviated" href="mailto:users@exim4u.org">users@exim4u.org</a>
<a class="moz-txt-link-freetext"
 href="https://exim4u.org/mailman/listinfo/users">https://exim4u.org/mailman/listinfo/users</a>


End of users Digest, Vol 2, Issue 2
***********************************

      </pre>
    </blockquote>
    <pre wrap="">


------------------------------

Message: 2
Date: Fri, 22 Jan 2010 17:37:07 -0500
From: Gordon Dickens <a class="moz-txt-link-rfc2396E"
 href="mailto:gecko@exim4u.org">&lt;gecko@exim4u.org&gt;</a>
Subject: Re: [Exim4U] domains got create at mysql level but not on
        system level
To: Exim4U General Discussion <a class="moz-txt-link-rfc2396E"
 href="mailto:users@exim4u.org">&lt;users@exim4u.org&gt;</a>
Message-ID: <a class="moz-txt-link-rfc2396E"
 href="mailto:4B5A2893.6060905@exim4u.org">&lt;4B5A2893.6060905@exim4u.org&gt;</a>
Content-Type: text/plain; charset="us-ascii"

An HTML attachment was scrubbed...
URL:
<a class="moz-txt-link-freetext"
 href="http://exim4u.org/pipermail/users/attachments/20100122/def115e8/attachment-0001.html">http://exim4u.org/pipermail/users/attachments/20100122/def115e8/attachment-0001.html</a>

------------------------------

_______________________________________________
users mailing list
<a class="moz-txt-link-abbreviated" href="mailto:users@exim4u.org">users@exim4u.org</a>
<a class="moz-txt-link-freetext"
 href="https://exim4u.org/mailman/listinfo/users">https://exim4u.org/mailman/listinfo/users</a>


End of users Digest, Vol 2, Issue 3
***********************************

    </pre>
  </blockquote>
  <pre wrap=""><!---->


_______________________________________________
users mailing list
<a class="moz-txt-link-abbreviated" href="mailto:users@exim4u.org">users@exim4u.org</a>
<a class="moz-txt-link-freetext"
 href="https://exim4u.org/mailman/listinfo/users">https://exim4u.org/mailman/listinfo/users</a>
  </pre>
</blockquote>
<br>
</body>
</html>